[dev-context] SciTE on linux

Taco Hoekwater taco at elvenkind.com
Tue Jan 17 16:13:24 CET 2006


Hi,

I now have a SciTE environment running on linux, but I've had to
tweak some stuff, that perhaps could be backported to the distro.

* Especially, setting up the font was a bit weird. The X font server
(at least the free version) does not understand OpenType fonts, so I
had to convert LMTypewriter10-Regular to truetype using fontforge,
then install the truetype font in X.

The system name became "LMTypewriter10 Regular", and the addition
of " Regular" is crucial. Just "LMTypewriter10" does not work.

Also, I found I needed to add an exclamation mark in from of the
name to get an antialiased font (it looks awful without that).

So I have changed the two lines in context.properties to:

   font.monospace=font:!LMTypewriter10 Regular,size:16.5
   font.errorfont=font:!LMTypewriter10 Regular,size:11.5

Now it works, with the exception that the top of a number of
characters like [ and ] is not displayed in a most font sizes
(that may be a problem caused by the auto-generated TTF font.
does it happen on windows as well?).


* I've changed the 'go' command so that it runs

   $(name.context.acrobat) $(FileName).pdf

system() on unix does not automatically resolve file extensions
like windows does, so the direct "$(FileName).pdf" did not work.


* I also had to create texmfstart: that command does not exist on
texlive (but it is in tetex 3.0).


Cheers, Taco
PS Shouldn't there be a cont-fr-scite.properties as well now?


More information about the dev-context mailing list