[dev-context] [NTG-context] Need a dot after float caption number (\floatcaptionsuffix)

Hans Hagen pragma at wxs.nl
Fri May 5 13:44:05 CEST 2006


Taco Hoekwater wrote:
> Hans Hagen wrote:
>> Taco Hoekwater wrote:
>>
>>> Jyrki Ruuskanen wrote:
>>>  
>>>
>>>> I edited page-flt.tex like so:
>>>>     
>>>
>>>
>>> This change has my vote as well.
>>>   
>>
>> what change 
>
> (from ntg-context)
>
> I edited page-flt.tex like so:
> 1423c1423
> <        \hbox{\doattributes{\??kj#1}\c!headstyle\c!headcolor{\strut#2
> \@@kjkjseparator}}%
> ---
>  >        \hbox{\doattributes{\??kj#1}\c!headstyle\c!headcolor
> {\strut#2\floatcaptionsuffix}}%
> 1824d1823
> <       \def\@@kjkjseparator {\getvalue{\??kj#4\c!separator}}%
>
> Which gives me the dot with \setupcaptions[separator=.].
hm, i've always a bit problems with reading such diff's; where did the 
floatcaptionsuffix go?


       
\hbox{\doattributes{\??kj#1}\c!headstyle\c!headcolor{\strut#2\floatcaptionsuffix\@@kjkjseparator}}%

anyway, it will *always* add a separatir which is not what i want, so: 

a next releas will provide: 

\setupcaptions[separator=!,stopper=?]


-----------------------------------------------------------------
                                          Hans Hagen | PRAGMA ADE
              Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
                                             | www.pragma-pod.nl
-----------------------------------------------------------------



More information about the dev-context mailing list