[dev-context] XeTeX fails to create formats

Hans Hagen pragma at wxs.nl
Wed Jan 3 22:57:07 CET 2007


Mojca Miklavec wrote:
> On 1/3/07, Hans Hagen wrote:
>   
>> Mojca Miklavec wrote:
>>     
>>> Hello Hans,
>>>
>>> when I tried to create XeTeX formats today (it might be that I screwed
>>> up something on my system as well) I got the following error:
>>>
>>> loading         : Context Encoding Macros (pdf)
>>> ! Undefined control sequence.
>>> l.63 \ifcase\pdfgentounicode
>>>                              \else \expandafter \endinput \fi
>>> ?
>>>
>>> Mojca
>>>
>>> (Is there any ctxtools --degrade? ;)
>>>
>>>       
>> no, but you have used a beta tree
>>
>> i was not aware of that not being loaded by xetex
>>
>> \beginXETEX \endinput \endXETEX
>>
>> at the top of the file
>>
>> should help
>>     
>
> Thanks, it works now (not as a one-liner, I had to split it in
> multiple lines for some reason, but I can now generate the formats
> just fine).
>   
does xetex put a unicode vector in the file (grep for ToUnicode) ; if 
needed disable compression

Hans

-- 

-----------------------------------------------------------------
                                          Hans Hagen | PRAGMA ADE
              Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
                                             | www.pragma-pod.nl
-----------------------------------------------------------------



More information about the dev-context mailing list