[dev-context] [tex-live] Debian TeX -- new packages

Frank Küster frank at debian.org
Thu Mar 29 11:09:39 CEST 2007


Sanjoy Mahajan <sanjoy at mrao.cam.ac.uk> wrote:

> I'll upgrade to the Ubuntu 7.04 beta, which will solve the libpng12-0
> problem because Ubuntu 7.04 uses libpng 1.2.15.  But libpoppler0c2
> would still be missing.  Here are the libpoppler pkgs in versions of
> Ubuntu:
>
> 5.04 (hoary)  | libpoppler0-0.1.2
> 5.10 (breezy) | libpoppler0c2-0.4.2
> 6.04 (dapper) | libpoppler1-0.5.1
> 6.10 (edgy)   | libpoppler1-0.5.4
> 7.04 (feisty) | libpoppler1-0.5.4
>
> So, could you add libpoppler1 as an alternative libpoppler dependency?
> That should fix the installation.  libpoppler1 is also in Debian (in
> experimental) so it should be a useful Debian change eventually.

No, we can't - these dependencies are autogenerated, and there's a
reason why libpoppler1 is not allowed.  Current TeXLive packages won't
even compile with libpoppler1, let alone run, and after changing the
patch to use libpoppler1, it won't compile with libpoppler0(c2).

Regards, Frank
-- 
Dr. Frank Küster
Single Molecule Spectroscopy, Protein Folding @ Inst. f. Biochemie, Univ. Zürich
Debian Developer (teTeX/TeXLive)


More information about the dev-context mailing list