schuster.wolfgang at googlemail.com
Thu Mar 29 21:33:22 CEST 2012
Am 29.03.2012 um 19:23 schrieb Hans Hagen:
> On 29-3-2012 18:38, Wolfgang Schuster wrote:
>> Am 29.03.2012 um 11:30 schrieb Hans Hagen:
>>> On 29-3-2012 10:46, Wolfgang Schuster wrote:
>>>> To many names aren’t a good solution but when I have to make a decision I would choose \definecounter because it’s the name which makes more sense. The only thing (besides backward compatibility) is the \makecounter mechanism which use the following commands:
>>> So will we drop the number ones then?
>> This would only work when you also drop \makecounter because it won’t be usable anymore when \definenumber will be changed to \definecounter.
> Well, a direct consequence of removing all 'structure' from 'structurecounter' is indeed that we get \definecounter and therefore need to drop the ones in syst-aux (no big deal as they are only used a few times and nowadays we have more than enough \count's; we can always turn them into \definevaluecounter or so if needed).
> Anyhow, I already did a lot of editing so there's no going back now ... I'm making a beta that you can check in a while. In the process \currentstructurecounter has become \currentsectioncountervalue and some macros got value appended as well.
It looks good and I will update my modules to use the new names but what’s with the following helper functions, will you provide synonyms for them or should I use these names (the commands are too useful to not use them myself):
More information about the dev-context