[Dev-luatex] compiling luatex with --with-system-zlib

Taco Hoekwater taco at elvenkind.com
Tue Aug 14 17:39:44 CEST 2007



Norbert Preining wrote:
> 
>> The main problem is that by default, it *only* configures and
>> builds against a pre-installed zlib. This is extremely bad, as I
> 
> Well, this is what we=Debian want ;-).

I know :-)

Perhaps I should just destroy its autoconf support completely. I
did that for fontforge, and that worked out reasonably well ...

>>> 	if (strncmp(version, ZLIB_VERSION, 5))
> 
> I guess the check could be good enough when checking only the first 3
> chars (major.minor) and NOT including the last .revision, but to be sure
> I do it for now with major.minor.revision.

Ok, applied that.

Best wishes,

Taco


More information about the dev-luatex mailing list