[Dev-luatex] LuaTeX dependencies

Joel C. Salomon joelcsalomon at gmail.com
Fri Dec 7 18:29:25 CET 2007


On Dec 7, 2007 4:32 AM, Martin Schröder <martin at oneiros.de> wrote:
> 2007/12/6, Joel C. Salomon <joelcsalomon at gmail.com>:
> > I'm considering porting LuaTεχ to Plan 9.  What libraries/compilers/
> > interpreters does the system have to have for this to work?
>
> Compilers: c and c++.

There's C++ code?  I looked through the source tree and was glad not
to see any.  Plan 9 uses a C compiler written by Ken Thompson and
doesn't have a C++ compiler.  (Well, someone just revived some ancient
cfront, but that doesn't count for much.)

Oh, I just found C++ code in lib/xpdf.  That's gonna be a problem.

> Do the configure scripts work on Plan 9?

Sort of, but they're really not considered useful for porting.

When I get my Plan 9 system up & running, I'll start trying to compile
the library components individually and will report on troubles here.
(And to the relevant library people, if applicable.)

Till then,
--Joel


More information about the dev-luatex mailing list