[Dev-luatex] beta 0.20.1 released

Aditya Mahajan adityam at umich.edu
Mon Dec 10 23:50:09 CET 2007


On Mon, 10 Dec 2007, Norbert Preining wrote:

> On Mo, 10 Dez 2007, Aditya Mahajan wrote:
>>> 	deb http://people.debian.org/~preining/TeX/ luatex/
>>> 	deb-src http://people.debian.org/~preining/TeX/ luatex/
>>>
>>> This release of luatex for Debian ships an improved texdoc written in
>>> texlua by Frank Küster. Please report any strange things to
>>> 	debian-tex-maint at lists.debian.org
>>
>> Excuse my ignorance, but is it safe to use these sources for ubuntu gusty
>> as well?
>
> Safe for sure, but you have to check whether it compiles. It depends on
> the version of libpoppler present in Ubuntu Gutsy.
>
> For libpoppler 0.4.X (X <= 8) take the etch variant
> For libpoppler 0.4.9 or 0.5.X you have to unpack the source package,
> 	change the debian/patches/series file to list the
> 	libpoppler-0.5 patch and comment the libpoppler-0.4 and -0.6
> For libpoppler 0.6.X take the sid variant (available at the same
> 	location as the etch variant but with terminal
> 		luatex-sid
> 	instead of luatex)
>
> Sorry for being of not so much help, but I don't have a gutsy around and
> I never could find out which versions of Ubuntu ship which versions of
> libraries.

Ubuntu gusty ships with libpoppler 0.6.2.1. However, I do not get any 
suggested updates because I am using amd64 architecture, and I see that 
you do not have amd64 packages on your website. I will wait for the new 
packages to trickle through to ubuntu repositories.

Aditya


More information about the dev-luatex mailing list