[Dev-luatex] Hyphenation pattern information are not logged?

Jonathan Sauer Jonathan.Sauer at silverstroke.com
Tue Dec 11 09:13:16 CET 2007


Hello,

LuaTeX does not seem to log the hyphenation memory usage anymore when
in IniTeX mode.

pdfTeX:

------------------------------------------------------------------------

This is pdfTeX, Version 3.141592-1.40.3 (Web2C 7.5.6) (INITEX)
entering extended mode
[...]
Beginning to dump on file ../web2c/ktex.fmt
 (format=ktex 2007.12.8)
3245 strings of total length 50066
8638 memory locations dumped; current usage is 64&8395
1676 multiletter control sequences
\font\nullfont=nullfont
0 words of font info for 0 preloaded fonts
14 hyphenation exceptions
Hyphenation trie of length 13987 has 388 ops out of 35111
  207 for language 1
  181 for language 0

------------------------------------------------------------------------

LuaTeX:

------------------------------------------------------------------------

This is LuaTeX, Version snapshot-0.20.0-2007120716 (Web2C 7.5.6)
(INITEX)
[...]
Beginning to dump on file ../web2c/luaktex.fmt
 (format=luaktex 2007.12.8)
2970 strings of total length 47739
45428 memory locations dumped; current usage is 48&8787
1788 multiletter control sequences
\font\nullfont=nullfont
0 preloaded fonts
0 words of active ocps
\ocp\nullocp=nullocp
0 preloaded ocps
\ocplist\nullocplist=[]

------------------------------------------------------------------------

I do not know if the new hyphenation mechanism still allows for logging
its memory usage, and if it is still deemed useful/necessary. I just
noticed this change since 0.11.2.


Jonathan



More information about the dev-luatex mailing list