[Dev-luatex] plain.tex with Latin Modern opentype fonts

Wlodek Bzyl matwb at univ.gda.pl
Thu May 22 20:31:49 CEST 2008


  Hi

  the latest luatex, when run with plain tex
  format with Latin Modern opentype fonts produces:

    segmentation fault, probably due to infinite macro recursion

   Backtracks from gdb prints:

#0  0x00a75802 in free () from /lib/libc.so.6
#1  0x080d33a6 in undump_font (f=1) at 
../../../../src/texk/web2c/luatexdir/font/texfont.c:1239
#2  0x0804bf5e in load_fmt_file () at luatexini.c:1240
#3  0x080546ed in main_body () at luatexini.c:2621
#4  0x080a7b76 in main (ac=3, av=0xbfc82864) at luatexextra.c:441

  I run into segmentation fault after:

  1. Replacing cmr fonts by latin modern fonts in plain.tex :

        wget http://julia.univ.gda.pl/~matwb/luaplain.tex

  2. Gluing, from different sources, a callback
     'define_font' function :

        wget http://julia.univ.gda.pl/~matwb/opentype.lua

  3. Dumping the luaplain format :

        luatex -ini -lua opentype.lua luaplain.tex
        \dump

  4. luatex -fmt luaplain
     **\end
     cat texput.log

This is LuaTeX, Version snapshot-0.25.3-2008052219 (Web2C 7.5.6)
                                            22 MAY 2008 20:17
**\end
! Emergency stop.
<*>
     \end
segmentation fault, probably due to infinite macro recursion

No pages of output.


   Is this segmentation fault my fault or luatex fault?

   Aha, today I am trying to generate a luatex format
   with the Polish patterns included.
   And this email describes my second unsuccessful attempt.

--Wlodek Bzyl




More information about the dev-luatex mailing list