[Dev-luatex] 0.60.2 fails to build on armel in CXXLD.sh

Taco Hoekwater taco at elvenkind.com
Mon Dec 20 14:21:05 CET 2010


Hi Peter,

Can you have a look at the CXXLD.sgh issue reported below?
The bug that is referred to is here:

   https://bugs.launchpad.net/ubuntu/+source/gcc-4.5/+bug/686381

and reading that will (hopefully) explain enough of the missing
quotations from the email exchange below.

Best wishes,
Taco


On 12/20/2010 02:13 PM, Jani Monoses wrote:
> On 12/20/2010 02:41 PM, Taco Hoekwater wrote:
>> On 12/20/2010 01:18 PM, Jani Monoses wrote:
>>> Hello,
>>>
>>> luatex fails to build on Ubuntu Natty
>>
>> Note that the current luatex is 0.65.0 (but it is unlikely
>> that that makes any difference).
>>
>>> Why is a static link needed btw? Does --disable-runtime-cxx-hack
>>> have some drawbacks?
>>
>> Luatex is normally built as part of texlive, and the texlive
>> distribution contains precompiled binaries for various platforms.
>> libc++ and the gcc libraries are linked statically to make the
>> generated binaries more portable, so no, for a local binary
>> you can disable the hack.
>>
> ok, thanks.
>
> According to a gcc involved commenter on the bugreport I linked to,
> the CXXLD.sh generation itself is incorrect, as he could fix the build
> by omitting some of the flags.
> So that still may be a luatex specific issue.
>
> Jani
>
>> However, I cannot guarantee that that fixes the problem. If a
>> symbol cannot be found using static linking, I do not have a lot
>> of faith in the runtime system being able to find it. You may
>> have to define -fno-exceptions in the CPPFLAGS instead.
>>
>> Best wishes,
>> Taco
>



More information about the dev-luatex mailing list