[Dev-luatex] Cron <luatex at boekplan> /var/www/luatex.org/www/bin/luatex-svn

Cron Daemon root at mail.boekplan.nl
Sun Nov 28 12:27:50 CET 2010


------------------------------------------------------------------------
r3991 | taco | 2010-11-28 09:08:07 +0100 (Sun, 28 Nov 2010) | 2 lines
Changed paths:
   M /trunk/manual/luatexref-t.pdf
   M /trunk/manual/luatexref-t.tex

clean up the primitives table

------------------------------------------------------------------------
r3992 | taco | 2010-11-28 09:24:21 +0100 (Sun, 28 Nov 2010) | 2 lines
Changed paths:
   M /trunk/source/texk/web2c/luatexdir/tex/mathcodes.w

restore backward compatibity for \meaning\mathchar

------------------------------------------------------------------------
r3993 | taco | 2010-11-28 10:09:19 +0100 (Sun, 28 Nov 2010) | 4 lines
Changed paths:
   M /trunk/source/texk/web2c/luatexdir/tex/linebreak.w

Fix an assert on 
  local Head = node.copy_list(head)
  tex.linebreak(Head) 

------------------------------------------------------------------------
r3994 | taco | 2010-11-28 10:38:01 +0100 (Sun, 28 Nov 2010) | 2 lines
Changed paths:
   M /trunk/source/texk/web2c/luatexdir/pdf/pdfpage.w

fix bug #525

------------------------------------------------------------------------
r3995 | taco | 2010-11-28 10:49:37 +0100 (Sun, 28 Nov 2010) | 3 lines
Changed paths:
   M /trunk/manual/luatexref-t.tex
   M /trunk/source/texk/web2c/luatexdir/tex/linebreak.w

ease the restriction on linebreak_filter: at least one hbox should be returned,
but that is not necessarily the last node (this fixes bug #526)

------------------------------------------------------------------------
r3996 | taco | 2010-11-28 11:26:06 +0100 (Sun, 28 Nov 2010) | 2 lines
Changed paths:
   M /trunk/source/texk/web2c/luatexdir/font/texfont.w

fix a memcpy() overrun in copy_font()

------------------------------------------------------------------------
r3997 | taco | 2010-11-28 11:37:21 +0100 (Sun, 28 Nov 2010) | 2 lines
Changed paths:
   M /trunk/source/texk/web2c/luatexdir/font/texfont.w

copy_font forgot to update the charinfo count, causing bug #486

------------------------------------------------------------------------


More information about the dev-luatex mailing list