[Dev-luatex] Problem using dfont fonts with lualatex (Mactex)

Hans Hagen pragma at wxs.nl
Wed Feb 9 23:07:15 CET 2011


On 9-2-2011 7:43, Beingalink wrote:
> I get following error message:
>
> -----------------------------------------------------------------------------------------------------------
> ! LuaTeX error ...0/texmf-dist/tex/luatex/luaotfload/otfl-luat-dum.lua:67: bad
> argument #2 to 'find_file' (invalid option 'truetype dictionary').
> <to be read again>
> \scan_stop:
> l.112 ...=MatchLowercase,Ligatures=TeX]{Helvetica}
> -----------------------------------------------------------------------------------------------------------
>
> Google told me that this might be related to code that originally came from context but wasn't changed to work with luatex. But I'm not sure since I'm not a developer. If there's sth. I can do to identify/fix the bug, please don't hesitate to tell me.

It depends on what the kpse library expects as so called 'format' so if 
you can try to change the "truetype dictionary" into "truetype font" and 
see what happens. (I cannot test it as in context we use other methods 
for locating the files).

Hans

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
                                              | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the dev-luatex mailing list