AW: [NTG-context] pdf 1.5 pb

Andreas Ulbrich ntg-context@ntg.nl
Thu, 20 May 2004 12:10:55 +0200


> > I've used Acrobat 6 to import and create .pdfs for=20
> inclusion as images, not thinking about compatibility mode=20
> (set by default on acrobat 6 I suppose).
> > When I try to texexec a .tex doc with such pdf inclusions,=20
> i get this output :
> > 	Error: pdfetex (file ./pieces-graphiques-l.pdf): pdf=20
> inclusion: found=20
> > pdf version <1.5>, but at most version <1.4> allowed  =3D=3D>=20
> Fatal error occurred, the output PDF file is not finished!
>=20
> You could try this:
>=20
> 	$ perl -npi.bak -e 's/%PDF-1.5/%PDF-1.4/;' *.pdf
>=20
> It might/might not work, I do not have any read PDF-1.5 =20
> files to test.

You can also use the Acrobat 6 PDF Optimizer (Acrobat 6 Menu: Advanced =
->
PDF Optimizer) to create PDF files in earlier PDF versions. I usually =
use
"compatible with acrobat 4" which works quite nicely with PDFTEX. I =
don't
quite understand why they didn't make that an option in the "save as" =
dialog
...

Gr=FC=DFe,

ulbi