[NTG-context] new ConTeXt versions

Hans Hagen pragma at wxs.nl
Wed Aug 25 13:25:13 CEST 2004


Thomas A.Schmitz wrote:

> I just used Taco's new script (which I find wonderful, thanks so 
> much!), and this made me realize a problem: the latest version of 
> ConTeXt should have updated texexec to version 4.4 -- and it did, sort 
> of. When I checked, it still said "texexec : TeXExec 4.0 - ConTeXt / 
> PRAGMA ADE 1997-2004." I then realized that the new versions of the 
> scripts sit in texmf/scripts/context, while the old versions (that are 
> still being called by the binary texexec) reside in 
> texmf/context/perltk. For the time being, I just copied them over (one 
> could also put softlinks in there, I suppose), but I wonder if this 
> behavior can be modified -- I coulnd't find anything in texexec.rme. 
> My system is tetex on Mac OS X. Anyone else have the same problems?

Welcome to the changes in tds and distributions. When you also update the binaries, you can use: 

textools --fixtexmftrees 

The scripts are loaded by so called stubs. If you want to play safe, use texmfstart instead: 

  texmfstart texexec.pl ..... 

The indirect way permits me to adapt things to changes in the tree (unfortunately those changes are not always downward compatible, but in texmfstart i can at least try to hide this) 

(see texmfstart manual for more features) 

Hans 

-----------------------------------------------------------------
                                          Hans Hagen | PRAGMA ADE
              Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
                                             | www.pragma-pod.nl
-----------------------------------------------------------------



More information about the ntg-context mailing list