[NTG-context] \setupURL issues

Adam Lindsay atl at comp.lancs.ac.uk
Thu Nov 18 17:00:02 CET 2004


Nikolai--

I just ran into this bug on my own and noticed your message on-list. Did
you get it resolved, cos you're right: it's ugly.

Nikolai Weibull said this at Mon, 5 Jul 2004 21:02:36 +0200:

>\setupURL
>  [color=blue]
>
>seems buggy.  Try this:
>
>\setupcolors
>  [state=start]
>\setupinteraction
>  [state=start]
>\setupurl
>  [color=blue]
>\useURL[one][http://www.google.com/]
>\starttext
>Why the hell is \from[one] wrapping so badly?
>\stoptext
>
>You will (hopefully...or something) notice that the http:// appears
>above and slightly to the left of www.google.com in the sentence.
>remove \setupurl[...] and it works fine, rendering it green.  It also
>works fine if you remove the color=blue and add style=type instead or
>whatever.  In noninteractive versions this works fine though and in
>documents without \setupcolors[state=start],
>	nikolai
>
>--
>::: name: Nikolai Weibull    :: aliases: pcp / lone-star / aka :::
>::: born: Chicago, IL USA    :: loc atm: Gothenburg, Sweden    :::
>::: page: www.pcppopper.org  :: fun atm: gf,lps,ruby,lisp,war3 :::
>main(){printf(&linux["\021%six\012\0"],(linux)["have"]+"fun"-97);}
>_______________________________________________
>ntg-context mailing list
>ntg-context at ntg.nl
>http://www.ntg.nl/mailman/listinfo/ntg-context

-- 
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
 Adam T. Lindsay, Computing Dept.     atl at comp.lancs.ac.uk
 Lancaster University, InfoLab21        +44(0)1524/510.514
 Lancaster, LA1 4WA, UK             Fax:+44(0)1524/510.492
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-



More information about the ntg-context mailing list