[NTG-context] Insufficient symbol fonts

Hans Hagen pragma at wxs.nl
Wed Jul 27 19:51:52 CEST 2005


Eckhart Guthöhrlein wrote:

>On Wed, 27 Jul 2005 at 15:27:47+0200, Taco Hoekwater wrote:
>  
>
>>TeX cannot find the math fonts that are defined by the presentation
>>style. There should be another error before this one, complaining
>>about missing font metrics.
>>    
>>
>
>In the output of 'texexec x >log 2>&1', there is nothing about metrics.
>The only messages concerning fonts are:
>
>bodyfont        : 12pt rm is loaded
>...
>fonts           : resetting map file list
>fonts           : using map file: original-base
>fonts           : using map file: ec-public-lm
>fonts           : using map file: ec-base
>fonts           : using map file: original-ams-base
>fonts           : using map file: original-public-lm
>
>  
>
>>The easiest fix is probably to make the presentation use
>>computer modern for math typesetting (?)
>>    
>>
>
>It does use cm, as far as I can see. I frequently use the \text command
>to get sans serif, since I don't have time and energy to figure out how
>to switch the default math fonts. (Ugly, I know...)
>
>Commands relevant to font setup in my environment:
>
>\setupbodyfont[17.28pt,sans]
>
>Nothing special, I think.
>Then I have some definitions like
>
>\definesymbol[alpha][\getglyph{cmmi10}{11}]
>\definesymbol[beta][\getglyph{cmmi10}{12}]
>
>because I intended to take these from a different (upright version) font
>in the future. Can this be the problem?
>
>  
>


-- 

-----------------------------------------------------------------
                                          Hans Hagen | PRAGMA ADE
              Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
                                             | www.pragma-pod.nl
-----------------------------------------------------------------



More information about the ntg-context mailing list