[NTG-context] texexec.ini not read

Hans Hagen pragma at wxs.nl
Wed Mar 1 10:40:24 CET 2006


Aditya Mahajan wrote:
> Oops, forgot to attach the logs
>
> <--- On Mar 1, Aditya Mahajan wrote --->
>
>> <--- On Feb 28, Aditya Mahajan wrote --->
>>
>>> I was trying to make the stand along context work with cygwin using
>>> cygwin ruby. Following the advice on the wiki of adding
>>> /scripts/context/ruby to rubylib, everything works fine. However, I am
>>> not able to enable write18. I copied texexec.rme to texexec.ini and
>>> added -shell-escape to all set TeXPassString in texexec.ini. However,
>>> I still get
>>>
>>> system(mpost .....) disabled
>>>
>>> in my log file. Reading through newtexexec.rb it seems that it does
>>> not check the ini file. Is this correct? Or am I missing something.
>>
>> Strange. If I run the command for dos command prompt, I get
>> system (mpost .....) executed
>>
>> It seems that texexec is looking at different profiles under cygwin.
>> Or rather, for some reason texexec can not find the correct file in
>> cygwin. I am attaching both log files. There is not much difference
>> there.
>>
>> It seems that I still need to work with cmd rather than bash :-(
>> Any hints will be appreciated.
>>
did you enable write 18 in texmf.cnf?

Hans

-----------------------------------------------------------------
                                          Hans Hagen | PRAGMA ADE
              Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
                                             | www.pragma-pod.nl
-----------------------------------------------------------------



More information about the ntg-context mailing list