[NTG-context] texfont error

Hans Hagen pragma at wxs.nl
Mon Sep 18 11:15:33 CEST 2006


Mojca Miklavec wrote:
> On 9/17/06, Hans Hagen wrote:
>   
>> Johan Sandblom wrote:
>>     
>>> Digging further reveals a working texfont.pl installed with debians
>>> texlive. The two texfonts claim to be the same version (in header) but
>>> are quite different. Both are included in the attached zip.
>>>
>>> R
>>>       
>
> But it's true that some variables ($lm and such) were added recently
> without declaring them first and adding some default value somewhere,
> so perl complains about "undeclared variables" (adding "my $lm" at the
> beginning surely helps, but that's not the only undeclared variable).
>
>   
>> hm, yuu can always run the latest with
>>
>> texmfstart texfont .....
>>
>> that will take the one from the tex tree
>>     
>
> The problem is exactly that: the latest version "doesn't work".
>
> But I can't comment much more - whenever I try to use it under windows
> I give up trying to find the cause of the problems and proceed
> manually (texfont claims to have produced such-and-such files, but no
> files are created and no checking is made whether they are produced or
> not - some steps which return an error are simply ignored).
>   
ah, i see, seems that i merged some code without declarations

Hans

-- 

-----------------------------------------------------------------
                                          Hans Hagen | PRAGMA ADE
              Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
                                             | www.pragma-pod.nl
-----------------------------------------------------------------



More information about the ntg-context mailing list