[NTG-context] lilypond newbie

Henning Hraban Ramm hraban at fiee.net
Thu May 10 21:02:33 CEST 2007


Am 2007-05-10 um 15:44 schrieb Arthur Reutenauer:
>   * The version of the Lilypond module on CTAN isn't actually that new
> since it dates back to September 2005 (according to the date of
> t-lilypond.pdf). Now even without that date, we can spot it in the  
> code
> since it mentions the version of Lilypond it was typed for (this is a
> general request in Lilypond); in that case it's 2.6; so Hraban meant
> your code was old, not your executable (current version is 2.10).

I meant both ;-)

I didn't even knew there was a version of t-lilypond on CTAN  
(overlooked that in Steffen's post).
(It's a known problem that ConTeXt versions on CTAN are often  
outdated, too.)
I should update the contextgarden version, but I wanted to wait if  
Aditya could find the error with Ruby texexec and clean up the code a  
bit.

>   In any case, just take the example from the file Hraban just posted
> and it should solve both problems (it does here). And Hraban should
> probably add a \version statement to his sample code ;-)

I was tired of the version statements in every snippet, so I let the  
module add a version statement.

It's impossible to take care of different LilyPond versions in one  
module, so I always try to stick with (and change syntax for) the  
latest - "always" meaning "everytime I work at a songbook".

LilyPond is a rather fast moving target, like ConTeXt, so some code  
becomes old very soon...

Greetlings from Lake Constance!
Hraban
---
http://www.fiee.net/texnique/
http://wiki.contextgarden.net
https://www.cacert.org (I'm an assurer)



More information about the ntg-context mailing list