[NTG-context] LuaTeX on Mac OS X

Otared Kavian otared at gmail.com
Thu Oct 11 21:26:27 CEST 2007


Dear Joeng, dear Thomas,

Thank you so much for your message and your invaluable help.
Indeed thanks to Thomas' instructions, after correcting a few  
details, I could install LuaTeX and typeset the file test-1.tex with  
the command

	texexec --lua test-1.tex

However, the execution stops with this error message:

	<everyjob> \the \everyloadluacode
    	                               \the \everyfinalizeluacode \the  
\everyjob

but after ignoring such messages with the command

	r

(meaning "run" without complaining...) I get the expected PDF file.

Since this is not yet a clean and thoroughly working installation, I  
have not yet tried to put the install informations on the Wiki. Later  
next week I'll try to re-install everything anew and see whether I  
have well understood what is needed to run LuaTeX on MacOS X.

Best regards: OK

On 11 oct. 2007, at 17:22, Jeong Dalyoung wrote:

> Dear Otared,
>
> Finally, luatools is working in my system.
>
> I reinstalled gwTeX and followed Thomas' instruction.
> Also I got an advice from Lutz.
> She said that use the latest Luatex and stable version of Context.
> Hence I installed stable version of the ConTeXt.
> I also saved environment variables in a file .luatex and run it  
> after open the terminal using 'source .luatex'
> After that luatools is working properly. As I wrote in the list, I  
> need to add a line 'trie_size=400000' in texmf.cnf
>
> I tested a short file and it was working properly.
> However, I have an error when I compile a sample file in the wiki.  
> I don't know why. I hope that someone answer to that question.
>
> Since I did it, you will do it. Maybe you already run luatools  
> properly.
>
> Thank you.
>
> Best regards,
>
> Dalyoung



More information about the ntg-context mailing list