[NTG-context] lua problem with Windows Vista

Mojca Miklavec mojca.miklavec.lists at gmail.com
Thu Mar 6 10:44:01 CET 2008


On Thu, Mar 6, 2008 at 9:57 AM, Thomas A. Schmitz
<thomas.schmitz at uni-bonn.de> wrote:
>
>  On Mar 6, 2008, at 9:45 AM, Johan Sandblom wrote:
>
>  > MkII seems to work after this but when I run
>  >
>  > luatools --generate
>  > luatools --ini --compile --verbose cont-en
>  >
>  > I get the output below which looks like a lua error. luatex version is
>  > snapshot-0.22.0-2008021623. I do not know enough about lua to track
>  > this error down. I am hoping someone knows what to do. Perhaps there
>  > is even someone who can tell me an easier way to install context on
>  > vista.
>
>  Hi Johan,
>
>  I think I had the same error; it will disappear when you upgrade to a
>  more recent snapshot of luatex. (The one on http://foundry.supelec.fr/projects/luatex
>   now is 0.22.1, but you may even need to compile from svn). As for
>  Vista, my best advice would be to install linux instead ;-)

I'm sorry - when I was updating the binaries (still missing for
mac-ppc and linux-64), there were no binaries from Akira available
yet, and I forgot to update a few days later.

This (new luatex) should be fixed now (but I still need to figure out
what goes wrong with the installation scripts on windows).

you can also use rsync -av contextgarden.net/minimals/pragma/mswin/

Mojca


More information about the ntg-context mailing list