[NTG-context] context minimal install problem? luatex bug?

Burak Emir burak.emir at gmail.com
Sat Jun 7 14:45:26 CEST 2008


p.s.: This may be the problem?

$  context test.texMtxRun | loading configuration for
/usr/local/context/tex/texmf/web2c from
/Users/buraq/luatex-cache/context/f70b0d481875d119766efabfbdb61af7/trees/01ff2a12d1aaf66ed1ecab879ab73b31
MtxRun | error
MtxRun | total runtime: 0.011

$ ls
/Users/buraq/luatex-cache/context/f70b0d481875d119766efabfbdb61af7/trees/01ff2a12d1aaf66ed1ecab879ab73b31
ls:
/Users/buraq/luatex-cache/context/f70b0d481875d119766efabfbdb61af7/trees/01ff2a12d1aaf66ed1ecab879ab73b31:
No such file or directory


On Sat, Jun 7, 2008 at 2:37 PM, Burak Emir <burak.emir at gmail.com> wrote:

> Hi Taco,
>
> Thanks for the quick response. I unset TEXMF, TEXMFMAIN and did `luatools
> --generate'. I also throw context/bin out of my PATH.
>
> First thing I notice: I can run context again (without parameters)
> But with test.tex, it still does not work:
>
> Burak-Emirs-MacBook-Pro:/tmp/testlua.a buraq$ context test.tex
> MtxRun | loading configuration for /usr/local/context/tex/texmf/web2c from
> /Users/buraq/luatex-cache/context/f70b0d481875d119766efabfbdb61af7/trees/01ff2a12d1aaf66ed1ecab879ab73b31
> MtxRun | error
> MtxRun | total runtime: 0.011
>
> output of  'env MTX_INPUT_TRACE=3 context test.tex':
>
> ? tex locator not found: %s | /usr/local/context/tex/texmf-project
> ? tex locator not found: %s | /usr/local/context/tex/texmf-fonts
> ? tex locator not found: %s | /usr/local/context/tex/texmf-local
> ! tex locator found: %s | /usr/local/context/tex/texmf-context
> = hash append: %s | /usr/local/context/tex/texmf-context
> ? tex locator not found: %s | /usr/local/context/tex/texmf-extra
> ! tex locator found: %s | /usr/local/context/tex/texmf
> = hash append: %s | /usr/local/context/tex/texmf
> ! using suffix based filetype: %s | lua
> ? blobpath asked: %s | context.lua
> ? blobpath do: %s (%s) | /usr/local/context/tex/texmf-context
> ? blobpath do: %s (%s) | /usr/local/context/tex/texmf
> ? filename: %s | context.lua
> - readable: %s | ./context.lua
> - readable: %s | ./context.lua
> - readable: %s | ./context.lua
> - readable: %s | ./context.lua
> ! using suffix based filetype: %s | lua
> ? blobpath asked: %s | mtx-context.lua
> ? blobpath do: %s (%s) | /usr/local/context/tex/texmf-context
> ? blobpath do: %s (%s) | /usr/local/context/tex/texmf
> ? filename: %s | mtx-context.lua
> - readable: %s | ./mtx-context.lua
> - readable: %s | ./mtx-context.lua
> - readable: %s | ./mtx-context.lua
> - readable: %s | ./mtx-context.lua
> = found in hash: %s |
> /usr/local/context/tex/texmf-context/scripts/context/lua/mtx-context.lua
> MtxRun | loading configuration for /usr/local/context/tex/texmf/web2c from
> /Users/buraq/luatex-cache/context/f70b0d481875d119766efabfbdb61af7/trees/01ff2a12d1aaf66ed1ecab879ab73b31
> MtxRun | error
> MtxRun | total runtime: 0.010
>
> Any idea what is going on?
>
> Burak
>
>
> On Sat, Jun 7, 2008 at 2:15 PM, Taco Hoekwater <taco at elvenkind.com> wrote:
>
>> Burak Emir wrote:
>> > p.s.: I figured out that I had an alias defined in my bash_profile
>> > alias context="ruby
>> > /usr/local/teTeX/share/texmf.local/scripts/context/ruby/texmfstart.rb
>> > texexec --luatex"
>>
>> I this may explain the dvi instead of pdf problem, but you also have
>> a configuration problem with mtxrun (that is not unheard of at all ...)
>>
>> >> # have coffee
>>
>> all good so far, no need to repeat any of it
>>
>> >> export
>> >>
>> PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/context/bin:/usr/local/context/tex/texmf-osx-intel/bin
>>
>> You don't actually need /usr/local/context/bin in the PATH I think,
>> but it should be harmless. Mojca?
>>
>> >> export TEXMF=/usr/local/context/tex/texmf
>> >> export TEXMFMAIN=$TEXMF
>>
>> This is BAD. You definately do not want to set TEXMF to that one
>> directory, and do not need either of the variables at all.
>> After removing these two from your environment and a manual
>>
>>   $ luatools --generate
>>
>> all should be well. If it is not, you should post the output of
>>
>>   $ env MTX_INPUT_TRACE=3 context test.tex
>>
>> for debugging purposes.
>>
>> Background information: It fails so miserably because if you set TEXMF,
>> it should have a small list of different locations, not just
>>    /usr/local/context/tex/texmf
>> In fact, most files live in
>>   /usr/local/context/tex/texmf-local
>> But simply not setting the variable at all should work just fine.
>>
>> Best wishes,
>> Taco
>>
>> ___________________________________________________________________________________
>> If your question is of interest to others as well, please add an entry to
>> the Wiki!
>>
>> maillist : ntg-context at ntg.nl /
>> http://www.ntg.nl/mailman/listinfo/ntg-context
>> webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
>> archive  : https://foundry.supelec.fr/projects/contextrev/
>> wiki     : http://contextgarden.net
>>
>> ___________________________________________________________________________________
>>
>
>
>
>
> --
> Burak Emir
> --
> http://burak.emir.googlepages.com
>



-- 
Burak Emir
--
http://burak.emir.googlepages.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.ntg.nl/pipermail/ntg-context/attachments/20080607/7d260934/attachment-0001.html 


More information about the ntg-context mailing list