[NTG-context] mpost manual

Hans van der Meer H.vanderMeer at uva.nl
Wed Dec 17 12:50:59 CET 2008


This might be considered a little off topic but I take the liberty to  
draw your attention to a problem with the mpost distribution. If there  
is really a problem with that distribution, I think it is in our  
interest to remedy it.

I made mpost from the mpost-1.101 distribution (sh build.sh), then  
updated mpost.mem and finally called make in the manual directory of  
this distribution. Surprisingly a faulty cmr10.tfm was flagged. The  
output being:

122 ~/TeX/metapost/metapost-1.101/manual: make
mpost -tex=tex mpman
This is MetaPost, version 1.101 (kpathsea version 3.5.7)
(./mpman.mp (/usr/local/texlive/2008/texmf-dist/metapost/base/boxes.mp)
! Font cmr10 not usable: TFM file is bad.
_s->...oup.addto._p.also(EXPR2)infont(EXPR3)scaled
                                                    
(EXPR4)shifted((EXPR5),(EX...
<argument> ..._n0="cmr10";_s("Figures",_n0,1,0,0,)
                                                   ;_s 
("in",_n0,1,35.3674,0,)...

beginbox_->...UFFIX2):=nullpicture;for._p_=(TEXT3)
                                                   :pic_ 
(SUFFIX2):=if.picture...

boxit->..."boxpath_","sizebox_",(SUFFIX2),(TEXT3))
                                                   ;generic_declare 
(pair)_n.s...
l.26 ....aa(btex \place{Figures in MetaPost} etex)
                                                   ;
As can be seen, I am using the texlive/2008 distribution (on Macintosh  
MACOSX 10.5.6).

Searching for cmr10.tfm delivers:
120 ~/TeX/metapost/metapost-1.101/manual: kpsewhich cmr10.tfm
/usr/local/texlive/2008/texmf-dist/fonts/tfm/public/cm/cmr10.tfm
Which should be fine in my opinion.

The question: Are there people out there who would be willing try the  
same and report the result? This is the first step to locate the  
problem: is this is local or does it occur elsewhere and on different  
systems too?

Hans van der Meer






More information about the ntg-context mailing list