[NTG-context] random bookmarks not linked (with example)

Steffen Wolfrum context at st.estfiles.de
Wed Feb 15 20:59:12 CET 2012


Dear developers, friends

please have a look at the bug described below!

It is not an academic detail ... 
It's a real book that's already have finished, containing hundreds of sections.
And unfortunately dozens of these cripples bookmarks.

I don't know what else I can do for debugging. Is there some advanced logging magic?


Please help!

Steffen


Am 15.02.2012 um 12:28 schrieb Steffen Wolfrum:

> Hi Hans,
> 
> finally I managed to figure out a "minimal" 3 page example that can reproduce this strange bug!
> 
> It seems to be an interaction of \cite and \index with sectioning/bookmark generation:
> Please run "chap_1.tex" and click on the bookmark "1.1.2 SIX" ... no destination is set.
> 
> (As I explained before, this does not mean that anything strange is going on at \subsection{SIX}.
> If the minimal file was longer, the missing link would have been somewhere else.)
> 
> If I delete the used \index entries the bug is gone.
> And if I delete the used \mycite commands the bug is gone, too.
> 
> 
> I hope this test file might help ...
> 
> Steffen
> -------
> <chap_01.tex>___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry to the Wiki!
> 
> maillist : ntg-context at ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
> archive  : http://foundry.supelec.fr/projects/contextrev/
> wiki     : http://contextgarden.net
> ___________________________________________________________________________________



More information about the ntg-context mailing list