[NTG-context] Strange error message

Otared Kavian otared at gmail.com
Sat Mar 10 22:10:22 CET 2012


Hi all,

Has anyone encountered the following situation with the betas from last January until today?
I have a document some 100 pages (each page being an \input), which is correctly typeset with ConTeXt version 2011.11.29 mkiv, but gives me the following error with the recent mkiv betas: the message is

<to be read again> 
                   }
<inserted text> ...onstructionparameter \c!level }
                                                  \setevalue {\??constructio...
\define_construction ... \everydefineconstruction 
                                                  \let \currentconstruction ...
<inserted text> ...r =\v!description ,\c!level =1]
                                                  \else \defineconstruction ...
\define_description ...he \everydefinedescription 
                                                  \let \currentdescription \...
<to be read again> 
                   \startpacked 
…

In order to localize the error I have tried to add little by little my \input files, and everything works when I have about 20 pages… 
I am reporting this issue just for debugging reasons, since for the real project I still use the 2011.11.29 version.
Indeed I should apologize since I am not able to submit a minimal example, my project itself being somewhat complex (at least from my perspective… not for a guru!).

Also, I should say that in recent previous betas the error message was different, but I have not anymore those versions to report what the exact message was.

Thanks for any insight: OK


More information about the ntg-context mailing list