[NTG-context] \goto[]…\reference[]{} in component files query

Alan Bowen bowenalan03 at gmail.com
Tue Apr 24 16:42:01 CEST 2012


I will try again adding more detail in the hope that this will help.

The following is not a minimal example but a bare outline of what I have
and where the problems with the cross-references arise.

This structure works with MKII, so the query is whether something has
changed in the command structure or whether the problem with
cross-references that Wolfgang mentioned some time ago still persists. If
the latter, it would be really good to if there is going to be a fix soon.

In either case, I need a solution: the journal lives on online and the
cross-references are essential to it. So any suggestions or news will be
gratefully received.

Alan
********************************************
\startproduct prd_Journal_vol-09

\setupinteraction[state=start,color=blue,%
contrastcolor=red,style=rm,display=new]

\component c_comp01
\component c_comp02

\stopproduct

%c_comp01
\startcomponent c_comp01

\at[abc] %this shows proper page number in blue
% and is an active link
\stopcomponent

%c_comp02
\startcomponent c_comp02

\Title[abc]{xxxxx}

pp. \at[abc]--\at[endcomp02] %shows correct page numbers in proper
 %colors but blue link goes to “page (null)”
\goto{the end}[endcomp02] %shows “the end” in blue
 %but link goes to “page (null)”

\reference[endcomp02]{}

\stopcomponent
********************************************
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20120424/df445992/attachment.html>


More information about the ntg-context mailing list