[NTG-context] \xmlcontext inoperative?

Hans Hagen pragma at wxs.nl
Wed May 9 16:47:12 CEST 2012


On 9-5-2012 14:53, Meer, H. van der wrote:
> Loaded xml with: xmlinclude{problem}{include}{file}
>
> Then called up parts of its contents through a setup:
> \startxmlsetups xam:define:get
> % The definition is the one with content.
> \xmldoiftext{#1}{.}{
>    \foundtrue
>    \xmlflush{#1}
>    \xmlcontext{#1}{.}
> }
> \stopxmlsetups
>
> The strange thing is that the \xmlflush typesets verbatim the contents of the node called up:
>
> <math version="2.0" xmlns="http://www.w3c.org/mathml">  <apply>  <eq/>  <ci>  f(x)</ci>  <apply>  <plus/>  <ci>  1</ci>  <apply>  <power/>  <ci>  x</ci>  <ci>  4</ci>  </apply>  <apply>  <power/>  <ci>  x</ci>  <ci>  7</ci>  </apply>  </apply>  </apply>  </math>
>
> but, to my surprise the \xmlcontext{#1}{.} lets it disappear completely. So does \xmlflushcontext{#1}. In other parts of the program \xmlcontext does what it should do, thus the mkvi format seems ok.
>
> What could have happened? Some detrimental effect of the \xmlinclude?

there is (if i remember right) an issue with the root node of an include 
that I need to look into (but not now as I need to be careful with 
compatibility)


-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
                                              | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list