[NTG-context] thelabel problem

luigi scarso luigi.scarso at gmail.com
Mon May 28 14:51:47 CEST 2012


On Mon, May 28, 2012 at 2:43 PM, Alfredo Catalina
<alfredo.catalina at gmail.com> wrote:
> I installed ConTeXt in 2009 in my laptop and wrote some documents. Now I
> have installed ConTeXt in other computer and tried to process some of those
> documents but it doesn't work.
>
> It looks that there is something wrong with Metapost/Metafun. I have tried a
> simple program like
>
> \starttext
>
> Testing
>
> \startuseMPgraphic{gh}
> draw thelabel.rt("the right way",a) withcolor .625red ;
> \stopuseMPgraphic
>
> \useMPgraphic{gh}
>
> \stoptext
>
> Then I get:
>
> system          > begin file kk2.tex at line 1
> metapost        > initializing instance 'metafun' using format 'metafun'
> metapost        > loading 'metafun.mp' (experimental metapost version two)
> ! terminal: >> a
>>> (3,0)
> ! Not implemented: (unknown numeric)+(pair).
> <to be read again>
>                    -
> thelabel->...((EXPR4)+labeloffset*laboff(SUFFIX2)-
>
> (labxf(SUFFIX2)*lrcorner.p...
> <*>  draw thelabel.rt("the right way",a)
>                                          withcolor .625red ; ;
> .
> system          > tex > error on line 10 in file kk2.tex: terminal: >> a
>>> (3,0)
> ! Not implemented: (unknown numeric)+(pair).
> <to be read again>
>                    -
> thelabel->...((EXPR4)+labeloffset*laboff(SUFFIX2)-
>
> (labxf(SUFFIX2)*lrcorner.p...
> <*>  draw thelabel.rt("the right way",a)
>                                          withcolor .625red ; ;
>
>
> Any ideas? Thank you.
>
>
> ___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry to
> the Wiki!
>
> maillist : ntg-context at ntg.nl /
> http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
> archive  : http://foundry.supelec.fr/projects/contextrev/
> wiki     : http://contextgarden.net
> ___________________________________________________________________________________

What is the value of a ?

This is ok with mkii

\setupcolors[state=start]
\starttext

Testing

\startuseMPgraphic{gh}
pair a;
a:=(0,0);
draw thelabel.rt("the right way",a) withcolor .625red ;
\stopuseMPgraphic

\useMPgraphic{gh}

\stoptext


-- 
luigi


More information about the ntg-context mailing list