[NTG-context] format generation fails in luat-fio.lua

Hans Hagen pragma at wxs.nl
Fri Jun 1 00:38:30 CEST 2012


On 1-6-2012 00:31, Philipp Gesang wrote:
> Hi all,
>
> I hit this bug during “context --make” after today’s update. Can
> somebody confirm this?  Must have been introduced since
> 2012.05.24 (according to the git logs, data-exp.lua has indeed
> been changed May 25).
>
> ········································································
> ! LuaTeX error ...text/tex/texmf-context/tex/context/base/data-exp.lua:97: invalid replacement value (a table)
> stack traceback:
>    [C]: in function 'lpegmatch'
>    ...text/tex/texmf-context/tex/context/base/data-exp.lua:97: in function 'splitpathexpr'
>    ...text/tex/texmf-context/tex/context/base/data-exp.lua:145: in function 'expandedpathfromlist'
>    ...text/tex/texmf-context/tex/context/base/data-res.lua:343: in function 'identify_configuration_files'
>    ...text/tex/texmf-context/tex/context/base/data-res.lua:1521: in function 'load'
>    ...text/tex/texmf-context/tex/context/base/luat-fio.lua:31: in main chunk
>    ...text/tex/texmf-context/tex/context/base/luat-cod.lua:42: in function 'registercode'
>    <main ctx instance>:1: in main chunk.
> \registerctxluafile ...ua.registercode("#1","#2")}
> ········································································

this issue is under investigation ... it's a problem with lpeg 0.10 in 
luatex (not texlua) ... best check out the latest (which reverts to 0.9) 
... btw, that version is not the production version

Hans


-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
                                              | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list