[NTG-context] gnuplot with ConTeXt standalone

Mojca Miklavec mojca.miklavec.lists at gmail.com
Wed Jun 6 09:47:04 CEST 2012


On Tue, Jun 5, 2012 at 5:00 PM, Xiao-Yong Jin wrote:
> Hi,
>
> I just tried out the ConTeXt standalone and found out it did not work with
> my gnuplot files.  I have been using texlive 2011, which works fine.  With
> the "context" command from standalone, the following error occurs,
>
> ----- Error begins -----
> ! Undefined control sequence.
>
> system          > tex > error on line 4 in file /Users/jin/pkgs/ConTeXt/tex/texmf-context/tex/context/base/cont-yes.mkiv: Undefined control sequence ...
>
>  1     %D \module
>  2     %D   [       file=cont-yes,
>  3     %D        version=2012.06.01,
>  4 >>  %D          title=\CONTEXT\ Miscellaneous Macros,
>  5     %D       subtitle=Startup Stub,
>  6     %D         author=Hans Hagen,
>  7     %D           date=\currentdate,
>  8     %D      copyright={PRAGMA ADE \& \CONTEXT\ Development Team}]
>  9     %C
> 10     %C This module is part of the \CONTEXT\ macro||package and is
> 11     %C therefore copyrighted by \PRAGMA. See mreadme.pdf for
> 12     %C details.
> 13
> 14     % At some point I will reconsider the \starttext .. \stoptext
>
>
> \startGNUPLOTpage ->\begingroup \obeyMPlines
>                                             \dostartGNUPLOTpage
> l.4 \startGNUPLOTpage
> ----- Error ends -----
>
> I am not really sure which line is the error.  Please excuse me if I pasted too much.
> The version of context from the standalone is
>
> ConTeXt  ver: 2012.06.05 09:16 MKIV  fmt: 2012.6.5  int: english/english
>
> As I have mentioned, the same file works fine with context in texlive 2011, which has
> version
>
> ConTeXt  ver: 2011.05.18 18:04 MKIV  fmt: 2012.4.5  int: english/english
>
> It looks like only two weeks difference.

If you do your calculations modulo 356 days, yes ;)

I need to wait for a huge macports update to finish (needs
recompilation of many big packages, including octave etc.) before I
will be able to use gnuplot again, but there is a fair chance that
either there is no gnuplot module installed in your standalone ConTeXt
installation (an extra --modules=gnuplot switch needed if I'm not
mistaken) or that something broke with yesterday's massive changes
(that 356 days joke wasn't meant seriously).

Please check if you have
    /Users/jin/pkgs/ConTeXt/tex/texmf-modules/tex/context/third/gnuplot/t-gnuplot.tex
    (kpsewhich t-gnuplot.tex)
on your system.

I'll take a look as soon as I have a working gnuplot binary back.

Mojca


More information about the ntg-context mailing list