[NTG-pdftex] [pdftex-Bugs][936] PDF image vpos wrong when PDF origin != 0

pdftex-bugs at sarovar.org pdftex-bugs at sarovar.org
Wed Apr 9 22:23:34 CEST 2008


Bugs item #936, was opened at 2008-04-09 00:40
Status: Open
Priority: 3
Submitted By: Hartmut Henkel (hhenkel)
Assigned to: Martin Schröder (oneiros)
Summary: PDF image vpos wrong when PDF origin != 0 
Resolution: None
Group: v1.50.0-alpha
Category: PDF inclusion


Initial Comment:
When a PDF image is embedded, and its /MediaBox contains a negative lly value, and if a depth != 0 is assigned with \pdfximage, the PDF image will be placed wrong vertically. the attached file cow1.pdf has a tweaked /MediaBox to force this effect. if this is a bug, it seems to be a rather longstanding one. see trivial patch to cure this.

----------------------------------------------------------------------

>Comment By: Hartmut Henkel (hhenkel)
Date: 2008-04-09 22:23

Message:
see PDF output for unpatched and patched pdftex in
bug-936.zip. The bug appears e. g., if one uses \pdfximage
with a non-zero depth parameter (pos. or neg.) together with
option "artbox". It happens only very seldom for "mediabox"
(default), as most MediaBoxes have 0 0 as their lower left
corner (i guess), and not many people are using \pdfximage
with a depth parameter anyway.

Regards, Hartmut

----------------------------------------------------------------------

Comment By: Martin Schröder (oneiros)
Date: 2008-04-09 01:03

Message:
Please attach a tex input file demonstrating the problem.

----------------------------------------------------------------------

You can respond by visiting: 
http://sarovar.org/tracker/?func=detail&atid=493&aid=936&group_id=106


More information about the ntg-pdftex mailing list