[Tex-nl] Twee bugs in grid met hhline en \tiny tabular

Pander pander at users.sourceforge.net
Tue Mar 15 09:46:21 CET 2011


On 2011-03-11 11:58, Wybo Dekker wrote:
> On vr, 2011-03-11 at 11:14 +0100, Pander wrote:
>> Hoi allemaal,
>>
>> Deze had ik ook naar comp.text.tex gestuurd maar tot zo ver nog geen
>> oplossing. Misschien weet een van jullie hoe dit aan te pakken.
>>
>> Het probleem wordt veroorzaakt door de settings voor baseline via
>> grid.sty. Het tijdelijk veranderen daarvan voor alleen deze tabellen
>> lost het denk ik op. Alleen weet ik niet goed hoe ik dat netjes met
>> grid.sty moet doen.

Nog iemand een mogelijke antwoord op bovenstaande paragraaf.

> Je mag inderdaad niet verwachten dat grid met de gekste fratsen rekening
> houdt, dus dat wordt een beetje rommelen. Ook kun je verticale belijning
> beter weglaten: die is lelijk en wordt door grid sowieso verstoord (zie
> de docs). Probeer dit eens, dat levert bovendien meer wit rond de hlines
> op; houd er rekening mee dat kleine variaties in dimens grote sprongen
> kunnen veroorzaken, door grid:

Voor de eerste tabel ben ik er nu bijna uit. Bedankt. Zie verder onder.

> \documentclass{article}
> \usepackage{multirow}
> \usepackage[fontsize=10pt,baseline=12pt,lines=52]{grid}
> \usepackage{ctable}
> \begin{document}
> \noindent
> {\Huge
>   \begin{tabular}{llr}\FL
>   \multirow{4}{*}{\normalsize Blah}&
>   \multirow{2}{*}{\normalsize Bluh}&
>       01234\NN
>       & & 56789\NN[.08ex]\cmidrule{2-3}
>       &
>       \multirow{2}{*}{\normalsize Bleh}&
> 	01234\NN
> 	& & 56789\LL
>       \end{tabular}
> }
> \strut\\
> {\tiny
>   \begin{tabular}{l}
> 	qwertyuiop\NN[1.9ex]
> 	asdfghjkl\NN[1.9ex]
> 	zxcvbnm\NN[1.9ex]
>   \end{tabular}
> }

Deze ziet er nog steeds anders uit dan {\tiny\begin{tabular}...} zonder
grid package. Ik denk dat grid tijdelijke uitschakelen of tijdelijk van
andere instellingen voorzien de beste oplossing is.

> \end{document}
> 
>> \documentclass{article}\usepackage{hhline}\usepackage{multirow}
>> %% The grid package:
>> %% - disturbes hhline in first tabular
>> %% - overlaps rows in second tabular
>> %%
>> %% How to fix both? Workarounds with locally different grid settings
>> %% in terms of fontsize, baseline, etcetera or temporarily disabling
>> %% grid are also welcome.
>> \usepackage[fontsize=10pt,baseline=12pt,lines=52]{grid}
>> \begin{document}
>> \noindent{\Huge\begin{tabular}{|l|l|r|}\hline
>> \multirow{4}{*}{\begin{tabular}{l}\normalsize Blah\end{tabular}}&
>> \multirow{2}{*}{\begin{tabular}{l}\normalsize Bluh\end{tabular}}&
>> 01234\\
>> &
>> &
>> 56789\\\hhline{|~|-|-|}
>> &
>> \multirow{2}{*}{\begin{tabular}{l}\normalsize Bleh\end{tabular}}&
>> 01234\\
>> &
>> &
>> 56789\\\hline
>> \end{tabular}}
>> \strut\\
>> {\tiny\begin{tabular}{l}
>> qwertyuiop\\
>> asdfghjkl\\
>> zxcvbnm\\
>> \end{tabular}}
>> \end{document}
>> _______________________________________________
>> TeX-NL mailing list
>> TeX-NL at ntg.nl
>> http://www.ntg.nl/cgi-bin/mailman/listinfo/tex-nl
> 
> 




More information about the TeX-NL mailing list